WP’de Warning: Cannot modify header information hatasını giderme

Merhaba arkadaşlar,

Bu makalemizde mysql database’imizde aşşağıdaki şekilde aldığımız hatayı nasıl gidereceğimiz hakkında bir ipucu vereceğim.

Warning: Cannot modify header information – headers already sent by (output started at C:\Inetpub\vhosts\user\httpdocs\wp-config.php:1) in C:\Inetpub\vhosts\user\httpdocs\wp-includes\pluggable.php on line 864

Olarak karşımıza geliyor.  Sadece bununla kalmaz Pluggable.php dosyası 674, 675 ve 676. satırlar içinde aynı şekilde hata verebilmekte. Bir başka versiyonu da Wp-login.php ‘nin on line 302, 314 gibi hatalar vermesi ile karşınıza gelebilir. Çözümü ise çok basittir.  Sorun Wp-config.php dosyasının karakter bozulmasından kaynaklanmakta.

FTP sunucunuza bağlanıp Wp-config.php dosyasını indirin Notepad++ editörü ile dosyayı açınız ve Notepad++ ‘nın “Biçim” menüsünden “Kodla (ANSI)” seçiniz. Dosyanızı kayıt edin kapatın ve FTP’ye tekrar gönderin.

Bu kadar basit…

Yaptığımız olay sadece Wp-config.php dosyasının karakter kodlamasını Notepad++ programı ile açıp ANSI’ye çevirmek. Bu değişiklikten sonra FTP sunucunuza dosyayı gönderdiğinizde WordPress’in sorunsuz çalıştığını göreceksiniz.

Yazar Hakkında Mustafa KURU


Bir cevap yazın

Your email address will not be published.